您的位置:首页 > 其它

ZOJ 3962 E - Seven Segment Display (数位DP)(2017浙江省赛E)

2017-04-26 16:52 633 查看
Seven Segment Display
Time Limit: 2 Seconds      Memory Limit: 65536 KB
A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays.
Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.
Edward, a student in Marjar University, is studying the course "Logic and Computer Design Fundamentals" this semester. He bought an eight-digit seven segment display component to make
a hexadecimal counter for his course project.
In order to display a hexadecimal number, the seven segment display component needs to consume some electrical energy. The total energy cost for display a hexadecimal number on the component
is the sum of the energy cost for displaying each digit of the number. Edward found the following table on the Internet, which describes the energy cost for display each kind of digit.

DigitEnergy Cost

(units/s)
06
12
25
35
44
55
66
73
DigitEnergy Cost

(units/s)
87
96
A6
B5
C4
D5
E5
F4
















For example, in order to display the hexadecimal number "5A8BEF67" on the component for one second, 5 + 6 + 7 + 5 + 5 + 4 + 6 + 3 = 41 units of energy will be consumed.
Edward's hexadecimal counter works as follows:
The counter will only work for n seconds. After n seconds the counter will stop displaying.
At the beginning of the 1st second, the counter will begin to display a previously configured eight-digit hexadecimal number m.
At the end of the i-th second (1 ≤ i < n), the number displayed will be increased by 1. If the number displayed will be larger than the hexadecimal number "FFFFFFFF" after increasing, the counter will set the number to 0
and continue displaying.
Given n and m, Edward is interested in the total units of energy consumed by the seven segment display component. Can you help him by working out this problem?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 105), indicating the number of test cases. For
each test case:
The first and only line contains an integer n (1 ≤ n ≤ 109) and a capitalized eight-digit hexadecimal number m (00000000
≤ m ≤ FFFFFFFF), their meanings are described above.
We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case output one line, indicating the total units of energy consumed by the eight-digit seven segment display component.

Sample Input

3
5 89ABCDEF
3 FFFFFFFF
7 00000000

Sample Output

208
124
327

Hint

For the first test case, the counter will display 5 hexadecimal numbers (89ABCDEF, 89ABCDF0, 89ABCDF1, 89ABCDF2, 89ABCDF3) in 5 seconds. The total units of energy cost is (7 + 6 + 6 +
5 + 4 + 5 + 5 + 4) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 6) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 2) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) = 208.
For the second test case, the counter will display 3 hexadecimal numbers (FFFFFFFF, 00000000, 00000001) in 3 seconds. The total units of energy cost is (4 + 4 + 4 + 4 + 4 + 4 + 4 + 4)
+ (6 + 6 + 6 + 6 + 6 + 6 + 6 + 6) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 2) = 124.
题解:
T的范围是1e5,算一下每一次询问的复杂度,显然只有1e2,由于每次是一个区间,我们很容易想到求前缀和然后求差,但是数据范围是1e9,显然是不能预处理的,那就想一下怎么在极低的复杂度下计算前缀和,这时就想到了数位dp,用这种方法求前缀和是O(8)级别的。

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

long long a[20]={6,2,5,5,4,5,6,3,7,6,6,5,4,5,5,4};
char c[20];
long long bit[10];
long long dp[20];
long long get_ans(long long x)
{
if(x<0) return 0;
long long pw=1,ans1=0;
for(int i=0;i<8;i++,pw*=16)
{
//ans1+=dp[a%16]*bit[i];
long long a1=x/(pw*16)*78;
long long b=dp[x/pw%16];
long long c=(x%pw+1)*a[x/pw%16];
ans1+=(a1+b)*pw+c;
}
return ans1;
}
long long char_num()
{
long long ans1=0;
for(long long i=0;i<=7;i++)
{
ans1*=16;
if(c[i]<='9'&&c[i]>='0')
ans1+=c[i]-'0';
else
{
ans1+=10+c[i]-'A';
}
}
return ans1;
}
int main()
{
long long t;
cin>>t;
dp[0]=0;
for(long long i=1;i<=16;i++)
dp[i]=dp[i-1]+a[i-1];
bit[0]=1;
for(int i=1;i<10;i++)
bit[i]=bit[i-1]*16;
long long mx=0xffffffff;
long long mm=get_ans(mx);
while(t--)
{
//memset(num,0,sizeof(num));
long long ss;
scanf("%lld",&ss);
scanf("%s",c);
long long dd=char_num();
dd--;
long long qq=dd+ss;
if(qq>mx)
{
printf("%lld\n",mm+get_ans(qq-mx-1)-get_ans(dd));
}
else
printf("%lld\n",get_ans(qq)-get_ans(dd));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: