您的位置:首页 > 其它

PAT-A-1010. Radix (25)

2017-04-26 00:00 316 查看


1010. Radix (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag"
is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10

Sample Output 1:
2

Sample Input 2:
1 ab 1 2

Sample Output 2:
Impossible

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<math.h>

using namespace std;

typedef long long LL;

char n1[30], n2[30],temp[30];
int number[300];
long long maxnum = (1LL << 63) - 1;

void init()
{
for (char c = '0'; c <= '9'; c++)
number[c] = c - '0';

for (char c = 'a'; c <= 'z'; c++)
number[c] = c - 'a' + 10;
}

LL tran(char a[], LL radix, LL numb)
{
long long ans = 0;
int len = strlen(a);
for (int i = 0; i < len; i++)
{
ans = ans*radix + number[a[i]];
if (ans<0 || ans>numb)
return -1;
}

return ans;
}

int maxdigit(char a[])
{
int ans = -1;
int len = strlen(a);
for (int i = 0; i < len; i++)
{
if (number[a[i]]>ans)
ans = number[a[i]];
}

return ans + 1;
}

int cmp(char a[], LL mid, LL t)
{
LL num = tran(a, mid, t);
if (num < 0)
return 1;

if (t>num)
return -1;
else if (num == t)
return 0;
else
return 1;

}

LL find(char a[], LL left, LL right, LL t)
{
LL mid;
while (left <= right)
{
mid = (left + right) / 2;
int flag = cmp(n2, mid, t);
if (flag == 0)
return mid;
else if (flag == -1)
left = mid + 1;
else
right = mid - 1;
}

return -1;
}

int main()
{
int tag, radix;
cin >> n1 >> n2 >> tag >> radix;
if (tag == 2)
{
swap(n1, n2);
/*strcpy(temp, n1);
strcpy(n1, n2);
strcpy(n2,temp);*/
}

init();
LL t = tran(n1, radix, maxnum);
LL low = maxdigit(n2);
LL high = t + 1;
LL ans = find(n2, low, high, t);

if (ans == -1)
cout << "Impossible" << endl;
else
cout << ans << endl;

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: