您的位置:首页 > 其它

Max Sum 最大连续和的子序列 HDU 1003 (一维序列DP)

2017-04-25 23:02 483 查看
[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6题意:给n个数字,求出n个数字最大的连续和,起始位置和终点位置是多少。思路:DP,当数字和小于0的时候重置,并记录起始位置,如果大于ans,则更新终止位置
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
using namespace std;
int main()
{
int n,t,icase=1;
scanf("%d",&t);
for(int icase=1;icase<=t;icase++)
{
scanf("%d",&n);
int ans=-100000000,s=-100000000,elem,st,en,mid;
for(int i=1;i<=n;i++){
scanf("%d",&elem);
if(s<0){
s=elem;
mid=i;
}
else
s+=elem;

if(s>ans) ans=s,en=i,st=mid;
}
printf("Case %d:\n",icase);
printf("%d %d %d\n",ans,st,en);
if(icase!=t)
printf("\n");
}
return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划