您的位置:首页 > 其它

Is It A Tree? (并查集)

2017-04-25 21:20 381 查看

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1173 Accepted Submission(s): 365
Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
 

Input

The
4000
input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 

Output

            For each test case display the line ``Case k is a tree.\\\\\\\" or the line ``Case k is not a tree.\\\\\\\", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


 

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


 

题意:判断最后组成的是不是一棵树;
注意事项:例如 1 2 1 2 0 0这种的不可以 1 2 2 1 0 0也不行(前两种用并查集判断) 1 1 2 2 0 0这种的也不行 (a != b 判断),每个节点(非根结点)的出度等于1,根结点的出度为0 ,森林也不是树

之前我还想判断 pre[b]的次数来判断 出度呢。。直接开一个数组记录不就好了,啊摔!

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string.h>
using namespace std;
const int MAX = 1000010;
bool visited[MAX];//是否访问过
int pre[MAX];//根结点
int conn[MAX];//入度
void init() {
for (int i = 0; i < MAX; ++i) {
visited[i] = 0;
pre[i] = i;
conn[i] = 0;
}
}

int find(int x) {
if (pre[x] == x)
return x;
pre[x] = find(pre[x]);
return pre[x];
}
void merge(int x, int y) {
int px = find(x);
int py = find(y);
if (px == py)
return;
pre[py] = pre[px];
}
int main() {
int Case = 1;
int n, m;
bool flag;
flag = true;
init();
while (scanf("%d %d", &n, &m) != EOF && n + m >= 0) {
if (!flag && n != 0 && m != 0)
continue;

if (n == 0 && m == 0) {
int root_num = 0;
for (int j = 1; j < MAX; ++j) {
if (visited[j] && find(j) == j)//检查访问过的点的根结点数目
root_num++;
if (conn[j] > 1) {//如果有节点入度大于1,则不是树
flag = false;
break;
}
}
if (root_num > 1)
flag = 0;
if (flag)
printf("Case %d is a tree.\n", Case++);
else
printf("Case %d is not a tree.\n", Case++);
flag = true;
init();
continue;
}
if ((m != n && find(n) == find(m)) || m == n)
flag = false;
else {
visited
= 1;
visited[m] = 1;
conn[m]++;
merge(n, m);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: