您的位置:首页 > 其它

poj-1651 Multiplication Puzzle(区间dp入门)

2017-04-25 16:17 357 查看
Multiplication Puzzle

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 9957 Accepted: 6152

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6

10 1 50 50 20 5

Sample Output

3650

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f
int dp[105][105];
int min(int a,int b){
return a>b?b:a;
}
int main(){
int a[105];
int n;
while(~scanf("%d",&n)){
int i,j,k,s;
for(i=1;i<=n;i++){
scanf("%d",&a[i]);
}
memset(dp,inf,sizeof(dp));

for(i=1;i<=n-2;i++){//初始化
dp[i][i+1]=0;//区间大小为1时;
dp[i][i+2]=a[i]*a[i+1]*a[i+2];//区间大小为2时;
}
dp[n-1]
=0;//补充;也可以用两个for循环写;
for(k=3;k<=n-1;k++){//控制区间大小
for(i=1,j=k+1;j<=n;j++,i++){//控制左右端点
for(s=i+1;s<j;s++){
dp[i][j]=min(dp[i][j],dp[i][s]+dp[s][j]+a[i]*a[s]*a[j]);
}
}
}
printf("%d\n",dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp 区间dp poj 1651