您的位置:首页 > 其它

HDU1425-sort

2017-04-25 00:57 267 查看


sort

                                                                            Time Limit: 6000/1000 MS (Java/Others)    Memory Limit:
65536/32768 K (Java/Others)

                                                                                                     Total Submission(s): 47715    Accepted Submission(s): 13763


Problem Description

给你n个整数,请按从大到小的顺序输出其中前m大的数。

 

Input

每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。

 

Output

对每组测试数据按从大到小的顺序输出前m大的数。

 

Sample Input

5 3
3 -35 92 213 -644

 

Sample Output

213 92 3

Hint请用VC/VC++提交

 

Author

LL

 

Source

ACM暑期集训队练习赛(三)

 

Recommend

linle

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const LL INF = 0x3f3f3f3f3f3f3f3f;
const double pi = acos(-1.0);
const double eps = 1e-8;

int a[1000005];

int main()
{
int n, m;
while (~scanf("%d%d", &n, &m))
{
for (int i = 0; i < n; i++) scanf("%d", &a[i]);
sort(a, a + n);
int flag = 0;
for (int i = 1; i <= m; i++)
{
if (flag++) printf(" ");
printf("%d", a[n - i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: