您的位置:首页 > 其它

POJ2602-Superlong sums

2017-04-25 00:32 344 查看
Superlong sums

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23240 Accepted: 6901
Description

The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with
maximal size of 1.000.000 digits.
Input

The first line of an input file contains a single number N (1<=N<=1000000) - the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next N lines
contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed N.
Output

Output file should contain exactly N digits in a single line representing the sum of these two integers.
Sample Input
4
0 4
4 2
6 8
3 7

Sample Output
4750

Hint

Huge input,scanf is recommended.
Source

Ural State University collegiate programming contest 2000

题意:给出两个长度为n的序列分别表示一个数,输出这两个数的和,第一行为一整数n表示两序列长度,之后n行每行两个数字(介于0到9之间)分别表示两序列相应位置的数字,并且保证两数和的位数不超过n

解题思路:模拟

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const double pi = acos(-1.0);
const double eps = 1e-8;

char a, b, c[1000006];

int main()
{
int n;
while (~scanf("%d", &n))
{
getchar();
for (int i = 0; i<n; i++)
{
a = getchar();
getchar();
b = getchar();
getchar();
c[i] = '0' + a - '0' + b - '0';
int t = i;
while (c[t]>'9')
{
c[t] -= 10;
c[--t] += 1;
}
}
for (int i = 0; i<n; i++)
putchar(c[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: