您的位置:首页 > 其它

POJ 2386 Lake Counting

2017-04-24 23:42 357 查看
Lake Counting

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 17917 Accepted: 9069

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12

W……..WW.

.WWW…..WWW

….WW…WW.

………WW.

………W..

..W……W..

.W.W…..WW.

W.W.W…..W.

.W.W……W.

..W…….W.

Sample Output

3

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N = 105;
int m,n;
char field
[N+1];

void dfs(int x , int y){
field[x][y] = '.';

for(int dx = -1 ; dx <=1 ; dx++){
for(int dy = -1 ; dy <=1 ; dy++){
int nx = x+dx;
int ny = y + dy;
if(0<=nx&&nx<n&&0<=ny&&ny<m&&field[nx][ny]=='W')
dfs(nx,ny);
}
}
}
int main(){
int res,i,j;
while(~scanf("%d%d",&n,&m))
{
res=0;
for(i=0;i<n;i++)
scanf("%s",field[i]);
for(i=0;i<n;i++)
for(j=0;j<m;j++)
if(field[i][j]=='W')
{
dfs(i,j);
res++;
}
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj