您的位置:首页 > 其它

最短路练习 8/poj/3660/Cow Contest

2017-04-24 14:04 148 查看
题目链接:http://poj.org/problem?id=3660

Cow Contest

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11308 Accepted: 6280
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will
always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results
of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5

Sample Output
2

题意:有n头牛,有m组关系,这m组关系不一定能得出所有的牛的排名,可能会有一些关系不确定,最多可以确定几头牛的排名。
思路:用Floyd:a>b,b>c 能得到a>c;     a>b,c>b得不出a和c;  所以关系是单向的;

有关系的为1,没关系的为0;最后确定一头牛的排名确定不确定,看 他若与其它牛的关系都确定,排名则确定。

最后统计数量。

可惜了,我到最后统计数量的时候没想到这个方法。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<string>
#define LL long long
#define eps 1e-8
using namespace std;
const int mod = 1e7+7;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6 +10;
int n,m,a,b;
int ma[105][105];
int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(ma,0,sizeof(ma));
for(int i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
ma[a][b]=1;
}
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
for(int k=1;k<=n;k++)
if(ma[j][i]&&ma[i][k])
ma[j][k]=1;
int sum,ans=0;
for(int i=1;i<=n;i++)
{
sum=0;
for(int j=1;j<=n;j++)
if(ma[i][j]||ma[j][i])
sum++;
if(sum==n-1)
ans++;
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  最短路