您的位置:首页 > 其它

POJ3255_Roadlocks_dijkstra求次短路

2017-04-24 11:46 176 查看
Roadblocks

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14318 Accepted: 5033
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the
shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination)
is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if
two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output
450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+25
bc15
0+100=450)

求次短路,只需要在最短路的基础上,替换一条边。使最短路增长的程度最小,就构成了次短路。

因为最短路上的每一条边都可能被替换,所以维护两个数组分别保存最短路和次短路。

为了防止MLE,这个题要用邻接表,不能用邻接矩阵。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#define f(x) x.first
#define s(x) x.second

using namespace std;

typedef pair<int, int> P;
const int inf = 0x3f7f7f7f;
const int maxn = 5010;
const int maxm = 100100;
int dis1 [maxn];
int dis2 [maxn];
int pre [maxm*2], head [maxn], no [maxm*2], va [maxm*2], tot;
int N, M;

void dijkstra ()
{
priority_queue<P, vector<P>, greater<P> > qu;
memset(dis1, inf, sizeof(dis1) );
memset(dis2, inf, sizeof(dis2) );
dis1[1] = 0;
qu.push(P(0, 1) );

while(qu.size() ){
int v = f(qu.top() ), t = s(qu.top() );
qu.pop();
if(v > dis2[t]) continue;

for(int i= head[t]; i != -1; i= pre[i]){
int pos = no[i], temp = v + va[i];//敲黑板

if(dis1[pos] > temp){
swap(dis1[pos], temp);
qu.push(P(dis1[pos], pos) );
}

if(dis2[pos] > temp && temp > dis1[pos]){
dis2[pos] = temp;
qu.push(P(dis2[pos], pos) );
}

}

}
}

void Insert (int a, int b, int d)
{
no[tot] = b;
va[tot] = d;
pre[tot] = head[a];
head[a] = tot;
tot ++;
}

int main ()
{
scanf("%d %d", &N, &M);

memset(head, -1, sizeof(head) );
for(int i= 1; i<= M; i++){
int a, b, d;
scanf("%d %d %d", &a, &b, &d);
Insert(a, b, d);
Insert(b, a, d);
}

dijkstra();

printf("%d\n", dis2
);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: