您的位置:首页 > 其它

(简单贪心)Bin Packing

2017-04-23 15:24 239 查看
A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that

each bin contains at most 2 items,

each item is packed in one of the q bins,

the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q .

Input
The first line of the input contains the number of items n (1<=n<=10
5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.

Output
Your program has to write the minimal number of bins required to pack all items.

Sample Input
10
80
70
15
30
35
10
80
20
35
10
30

Sample Output
6

Hint
The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order. 

思路:贪心

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
#include<iostream>
int n,l;
int a[100010];
int main()
{
cin>>n>>l;
for(int i=0;i<n;++i)
cin>>a[i];
sort(a,a+n);
int sum=0;
int len=0;
int temp=n-1;
for(int i=0;i<n;i++)
if(a[i]>0)
{
if(a[i]<l)
{
for(int j=temp;j>i;--j)
{
if(a[j]>0&&a[j]+a[i]<=l)
{
a[j]=-1;
temp--;
break;
}
}
}
a[i]=-1;
sum++;
}
printf("%d\n",sum);
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: