您的位置:首页 > 编程语言 > C语言/C++

hdu 2055 An easy problem

2017-04-23 12:47 381 查看

Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output

for each case, you should the result of y+f(x) on a line.

Sample Input

6

R 1

P 2

G 3

r 1

p 2

g 3

Sample Output

19

18

10

-17

-14

-4

分析

直接计算相应的偏移即可

代码

#include <iostream>
#include <string>
#include <algorithm>

using namespace std;

int main()
{
int n;
cin>>n;
while(n--)
{
char str;
int num;
int res = 0;
cin>>str>>num;
if(str >= 'a' && str <= 'z')
{
res += 0 - (str - 'a' + 1);
}
else
{
res += str - 'A' + 1;
}
res += num ;
cout<<res<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++