您的位置:首页 > 其它

浙江省赛 D Let's Chat

2017-04-23 11:47 260 查看
ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described
as follows:

If two users, A and B, have been sending messages to each other on the lastm
consecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i -m + 1)-th day and the
i-th day (both inclusive), and user B also sent messages to user A on each day between the (i -m + 1)-th day and the
i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of thei-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of then-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer
T (1 ≤ T ≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109),m (1 ≤
m ≤ n), x and y (1 ≤x,
y ≤ 100). The meanings of n and m are described above, whilex indicates the number of chatting logs about the messages sent by A to B, andy indicates the number of chatting logs about the messages sent by B
to A.

For the following x lines, the i-th line contains 2 integersla,
i and ra,i (1 ≤
la,i ≤
ra,i ≤
n), indicating that A sent messages to B on each day between thela,
i-th day and the ra,i-th day (both inclusive).

For the following y lines, the i-th line contains 2 integerslb,
i and rb,i (1 ≤
lb,i ≤
rb,i ≤
n), indicating that B sent messages to A on each day between thelb,
i-th day and the rb,i-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < x, ra,i + 1 <
la,i + 1 and for all 1 ≤
i < y, rb,i + 1 <
lb,i + 1.

Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of then-th day.

Sample Input

2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5

Sample Output

3
0

思路:贪心算法:观察可以转化为区间上的公共部分的问题

#include <iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int x[105][105],y[105][105];
int main()
{
int icase;
// freopen("e:\\in.txt","r",stdin);
scanf("%d",&icase);
while(icase--)
{
int n,m,X,Y;
scanf("%d%d%d%d",&n,&m,&X,&Y);
for(int i=1;i<=X;i++)
for(int j=1;j<=2;j++)
scanf("%d",&x[i][j]);

for(int i=1;i<=Y;i++)
for(int j=1;j<=2;j++)
scanf("%d",&y[i][j]);

int re=0;
for(int i=1;i<=X;i++)
{
if(x[i][2]-x[i][1]<m-1)
continue;
for(int j=1;j<=Y;j++)
{
if(y[j][2]-y[j][1]<m-1)
continue;
int l=max(y[j][1],x[i][1]),
r=min(x[i][2],y[j][2]),
length=r-l+1;
if(length>=m)
re+=length-m+1;
}
}
printf("%d\n",re);
}
return 0;
}


Hint

For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. Asm = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer
is 3.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: