您的位置:首页 > 编程语言 > Go语言

Gold Balanced Lineup

2017-04-22 19:56 197 查看
/*Gold Balanced Lineup

Farmer John’s N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared

by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows

exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its “feature ID”, a single K-bit integer whose binary representation

tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is

1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in

the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat “balanced” in

terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by

the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine

it.

Input

Line 1: Two space-separated integers, N and K.

Lines 2..N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this

integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature #K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3

7

6

7

2

1

4

2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range*/

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
using namespace std;
const int N=15000;
const int Mod=14997;
struct Node
{
int a[35];
int count;
};
vector<Node> hash
;
bool solve(Node x,Node y,int k)
{
for(int i=0;i<k;i++)
{
if(x.a[i]!=y.a[i])
return false;
}
return true;
}
int main()
{
int n,k;
while(~scanf("%d%d",&n,&k))
{
int cmp[35]={0};
int max=0;
for(int i=0;i<n;i++)
{
int x;
scanf("%d",&x);
for(int j=0;j<k;j++)
{
cmp[j]+=x%2;
x/=2;
}
Node ans;
int sum=0,flag=1;
ans.a[0]=0;
for(int j=1;j<k;j++)
{
ans.a[j]=cmp[j]-cmp[0];
if(ans.a[j]!=ans.a[j-1])
flag=0;
sum=(sum+(ans.a[j]*(j+7)))%Mod;
}
if(flag)
{
if((i+1)>max)
max=i+1;
}
sum=(sum+15000)%Mod;
ans.count=i;
hash[sum].push_back(ans);
}
if(n==1)
{
int ok=1;
for(int i=1;i<k;i++)
{
if(cmp[i]!=cmp[i-1])
ok=0;
}
if(ok)
printf("1\n");
else
printf("0\n");
hash[0].clear();
continue;
}
if(max>1)
{
printf("%d\n",max);
continue;
}
for(int i=0;i<15000;i++)
{
if(hash[i].size()>1)
{
for(int j=0;j<hash[i].size()-1;j++)
{
for(int f=j+1;f<hash[i].size();f++)
{
if(solve(hash[i][j],hash[i][f],k))
{
int zhi=fabs(hash[i][j].count-hash[i][f].count);
if(zhi>max)
max=zhi;
}
}
}
}
hash[i].clear();
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: