您的位置:首页 > 其它

poj-1050-To the Max

2017-04-22 11:30 232 查看

To the Max

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 48613 Accepted: 25704

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0 9 2 -6 2

-4 1 -4 1 -1

8 0 -2

Sample Output

15

题意:给出一个矩阵,让求出最大子矩阵和

思路:先单独对每行求最大字段和

然后,把第i行后的各行对应列的元素加到第i行的对应列元素,每加一行,就求一次最大字段和,这样就把子矩阵的多行压缩为一行了,一行了就是最大字段和了

也可以这样理解:

如矩阵:

a11 a12 a13

a21 a22 a23

a31 a32 a33

如图,先求第一行最大子段和,再求第一行跟第二行合起来的最大子段和,如a21+a11, a22+a12, a23+a13 的最大子段和,再求第一到第三合起来的最大子段和,如a11+a21+a31, a12+a22+a32, a13+a23+a33的最大子段和,如此以a11为首第一行到最后一行之间的子矩阵可以求出一个最大子矩阵值,接下来第二行最大子段和,第二行和第三行的最大子段和,第三行最大字段和………..以此类推,直到求出整个矩阵的合起来的最大子段和,求出他们之中最大的那个和就是解。

代码:

#include <Stdio.h>
int n,max;
int map[105][105];
int find(int k)//寻找最大值
{
int i,j,t=0;
for(i=1;i<=n;i++)
{
if(t>0){
t+=map[k][i];
}//t>0时加
else    t=map[k][i];//小于等于0,t可以等于0也可以等于map[k][i]
if(t>max)   max=t;//找出最大值
}
return max;
}
int main()
{
int i,j,k;
max=-0x3f3f3f3f;
scanf("%d",&n);
for(i=1;i<=n;i++){
for(j=1;j<=n;j++){
scanf("%d",&map[i][j]);
}
}

for(i=1;i<=n;i++)//以i行为首向下
{
find(i);//先求出第i行的最大字段和
for(j=i+1;j<=n;j++)//行
{
for(k=1;k<=n;k++)//列
{
map[i][k]+=map[j][k];
}
find(i);
}
}

printf("%d\n",max);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: