您的位置:首页 > 其它

poj 3264 Balanced Lineup(基础线段树)

2017-04-21 18:25 441 查看

Balanced Lineup

Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3

1

7

3

4

2

5

1 5

4 6

2 2

Sample Output

6

3

0

ps:很基础的线段树了吧。。

代码:

#include<stdio.h>
#include<string.h>

#define maxn 50010
struct node
{
int min_val,max_val,le,ri;
int mid()
{
return (le+ri)>>1;
}
} tree[maxn*4];
struct Num
{
int min_v,max_v;
Num(int x,int y)//构造函数
{
min_v=x;
max_v=y;
}
};
int a[maxn];

int Min(int x,int y)
{
return x<y?x:y;
}

int Max(int x,int y)
{
return x>y?x:y;
}

void Build(int rt,int left,int right)
{
tree[rt].le=left;
tree[rt].ri=right;
if(left==right)
{
tree[rt].min_val=tree[rt].max_val=a[left];
return ;
}
int mid=tree[rt].mid();
Build(rt<<1,left,mid);
Build(rt<<1|1,mid+1,right);
tree[rt].max_val=Max(tree[rt<<1].max_val,tree[rt<<1|1].max_val);
tree[rt].min_val=Min(tree[rt<<1].min_val,tree[rt<<1|1].min_val);
}

Num Query(int rt,int left,int right)//返回两个参数
{
if(tree[rt].le==left&&tree[rt].ri==right)
return Num(tree[rt].min_val,tree[rt].max_val);
int mid=tree[rt].mid();
if(right<=mid)
return Query(rt<<1,left,right);
else if(left>mid)
return Query(rt<<1|1,left,right);
else
{
Num q1=Query(rt<<1,left,mid);
Num q2=Query(rt<<1|1,mid+1,right);
int max_val=Max(q1.max_v,q2.max_v);
int min_val=Min(q1.min_v,q2.min_v);
return Num(min_val,max_val);
}
}

int main()
{
int n,m,x,y;
scanf("%d%d",&n,&m);
for(int i=1; i<=n; ++i)
scanf("%d",&a[i]);
Build(1,1,n);
for(int i=1; i<=m; ++i)
{
scanf("%d%d",&x,&y);
Num q=Query(1,x,y);
printf("%d\n",q.max_v-q.min_v);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: