您的位置:首页 > 其它

ZOJ-BREAK STANDARD WEIGHT

2017-04-20 22:56 369 查看
题意:

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which
is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used
with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights1 and
5, we can measure the object with mass 1,
4
, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses arex and
y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are4 and
9, if you break the second one into 4 and
5
, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into1 and
3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input
There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integersx and
y. 2 ≤ x, y ≤ 100

Output
For each test case, output the maximum number of possible special masses.

Sample Input
2
4 9
10 10

Sample Output
13
9


分析:无脑暴力。。写两个循坏。。


#include <bits/stdc++.h>
using namespace std;
int zz[11111];
int main()
{
int T;
while(scanf("%d",&T)!=EOF)
{
int n,m;
while(T--)
{
scanf("%d%d",&n,&m);
int a,b,c;
int ma=-1,mb=-1;
int i,j,l;
for(l=1;l<=n;l++)
{
memset(zz,-1,sizeof(zz));
a=l,b=n-l,c=m;
zz[1]=abs(a);
zz[2]=abs(b);
zz[3]=abs(c);
zz[4]=abs(a+c);
zz[5]=abs(b+c);
zz[6]=abs(a+b);
zz[7]=abs(a-b);
zz[8]=abs(a-c);
zz[9]=abs(b-c);
zz[10]=abs(c+b-a);
zz[11]=abs(c+a-b);
zz[12]=abs(b+a-c);
zz[13]=abs(b+a+c);
int mm=13;
for(i=1;i<13;i++)
{
for(j=i+1;j<=13;j++)
{
if(zz[i]==0)
{
mm--;
break;
}
if(zz[i]==zz[j])
{
mm--;
break;
}
}
}
if(mm>ma)
{
ma=mm;
}
}
for(l=1;l<=m;l++)
{
memset(zz,-1,sizeof(zz));
a=l,b=m-l,c=n;
zz[1]=abs(a);
zz[2]=abs(b);
zz[3]=abs(c);
zz[4]=abs(a+c);
zz[5]=abs(b+c);
zz[6]=abs(a+b);
zz[7]=abs(a-b);
zz[8]=abs(a-c);
zz[9]=abs(b-c);
zz[10]=abs(c+b-a);
zz[11]=abs(c+a-b);
zz[12]=abs(b+a-c);
zz[13]=abs(b+a+c);
int mm=13;
for(i=1;i<13;i++)
{
for(j=i+1;j<=13;j++)
{
if(zz[i]==0)
{
mm--;
break;
}
if(zz[i]==zz[j])
{
mm--;
break;
}
}
}
if(mm>mb)
{
mb=mm;
}
}
if(mb>ma)
printf("%d\n",mb);
else
{
printf("%d\n",ma);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ZOJ