您的位置:首页 > 运维架构

POJ LITTLE SHOP OF FLOWERS(动态规划)

2017-04-20 20:13 274 查看
LITTLE SHOP OF FLOWERS

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21377 Accepted: 9886
Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through
V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine
the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2)
and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations.
If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has
an aesthetic value of 0. 
 V A S E S
1
2
3
4
5
Bunches
1 (azaleas)
723-5-2416
2 (begonias)
521-41023
3 (carnations)
-21
5-4-2020
According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have
to produce exactly one arrangement. 

Input

The first line contains two numbers: F, V.
The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.

1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 

F <= V <= 100 where V is the number of vases. 

-50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.
Sample Input
3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output
53

Source

IOI 1999
http://poj.org/problem?id=1157
输入F束花 V个瓶子 每个瓶子插在各个瓶子是有各自的价值的 花必须插完 问最大的价值

有个条件是每次插花必须在前面所有已经插的花的后面

DP 每次操作都可以从前面的状态递推过来 注意这个条件

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[110][110],ap[110][110];

int main()
{
int f,v,i,j,maxx,k;
while(scanf("%d %d",&f,&v)!=EOF)
{
for(i=1; i<=f; i++)
for(j=1; j<=v; j++)
scanf("%d",&ap[i][j]);

memset(dp,0,sizeof(dp));

for(i=1; i<=v; i++)
dp[1][i]=ap[1][i];

for(i=2; i<=f; i++)
for(j=i; j<=v; j++) //插在J瓶子的时候最大的价值
{
dp[i][j]=-0x3f3f3f3f;
for(k=i-1; k<j; k++)//从J瓶子前面找最大的
{
dp[i][j]=max(dp[i][j],dp[i-1][k]+ap[i][j]);
}
}

maxx=-0x3f3f3f3f;
for(i=1; i<=v; i++)
maxx=max(maxx,dp[f][i]);
printf("%d\n",maxx);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj