您的位置:首页 > 产品设计 > UI/UE

UVA 11538 Chess Queen

2017-04-20 14:55 253 查看
You probably know how the game of chess is played and how chess queen operates. Two chess queens

are in attacking position when they are on same row, column or diagonal of a chess board. Suppose

two such chess queens (one black and the other white) are placed on (2 × 2) chess board. They can be

in attacking positions in 12 ways, these are shown in the picture below:

Figure: in a (2 × 2) chessboard 2 queens can be in attacking position in 12 ways

Given an (N × M) board you will have to decide in how many ways 2 queens can be in attacking

position in that.

Input

Input file can contain up to 5000 lines of inputs. Each line contains two non-negative integers which

denote the value of M and N (0 < M, N ≤ 106

) respectively.

Input is terminated by a line containing two zeroes. These two zeroes need not be processed.

Output

For each line of input produce one line of output. This line contains an integer which denotes in how

many ways two queens can be in attacking position in an (M × N) board, where the values of M and

N came from the input. All output values will fit in 64-bit signed integer.

Sample Input

2 2

100 223

2300 1000

0 0

Sample Output

12

10907100

11514134000

【分析】

写一写刘汝佳放松心情…

题意:给你一个n*m的棋盘,放两个皇后,问有多少种放法可以使两个皇后相互攻击。注意两个皇后本质不同。

考虑横着攻击,竖着攻击,斜着攻击,累加得到答案。

【代码】

#include<iostream>
#include<cstring>
#include<cstdio>
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int mxn=100005;
unsigned long long n,m,ans;
int main()
{
int i,j;
while(cin>>n>>m)
{
if(!n && !m) return 0;
if(n>m) swap(n,m);
cout<<n*m*(n+m-2)+2*(m-n+1)*n*(n-1)+2*n*(n-1)*(n+n-1)/3-2*n*(n-1)<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: