您的位置:首页 > 其它

poj 3468 A Simple Problem with Integers 线段树区间更新

2017-04-20 14:30 543 查看
点击打开链接题目链接

A Simple Problem with Integers

Time Limit: 5000MSMemory Limit: 131072K
Total Submissions: 63565Accepted: 19546
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is
to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

给出n个数q次操作

C代表把a到b间的数分别加c

Q要求输出和

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=111111;
long long sum[MAXN<<2];
long long lazy[MAXN<<2];
void pushup(int rt)
{
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
if(lazy[rt])
{
lazy[rt<<1]+=lazy[rt];
lazy[rt<<1|1]+=lazy[rt];
sum[rt<<1]+=lazy[rt]*(m-(m>>1));
sum[rt<<1|1]+=lazy[rt]*(m>>1);
lazy[rt]=0;
}
}
void build(int l,int r,int rt)
{
lazy[rt]=0;
if(l==r)
{
scanf("%lld",&sum[rt]);
return ;
}
int mid=(l+r)>>1;
build(l,mid,rt<<1);
build(mid+1,r,rt<<1|1);
pushup(rt);
}
void update(int L,int R,int c,int l,int r,int rt)
{
if(l>=L&R>=r)
{
lazy[rt]+=c;
sum[rt]+=(long long)c*(r-l+1);
return ;
}
pushdown(rt,r-l+1);
int mid=(l+r)>>1;
if(L<=mid)
update(L,R,c,l,mid,rt<<1);
if(R>mid)
update(L,R,c,mid+1,r,rt<<1|1);
pushup(rt);
}
long long query(int L,int R,int l,int r,int rt)
{
if(l>=L&&R>=r)
{
return sum[rt];
}
pushdown(rt,r-l+1);
int mid=(l+r)>>1;
long long cnt=0;
if(L<=mid)
cnt=query(L,R,l,mid,rt<<1);
if(R>mid)
cnt+=query(L,R,mid+1,r,rt<<1|1);
return cnt;
}
int main()
{
int n,q;
char op[2];
int a,b,c;
while(scanf("%d %d",&n,&q)!=EOF)
{
build(1,n,1);
//printf("%d\n",sum[1]);
while(q--)
{
scanf("%s",op);
if(op[0]=='Q')
{
scanf("%d %d",&a,&b);
printf("%lld\n",query(a,b,1,n,1));
}
else
{
scanf("%d %d %d",&a,&b,&c);
update(a,b,c,1,n,1);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: