您的位置:首页 > 理论基础 > 数据结构算法

hdu 1159 最长公共子序列LCS

2017-04-20 11:00 351 查看


Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 37971    Accepted Submission(s): 17411


Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y. 

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line. 

 

Sample Input

abcfbc abfcab
programming contest
abcd mnp

 

Sample Output

4
2
0

 

Source

Southeastern Europe 2003

大意就是:求两个字符串的最长公共子序列;

#include <stdio.h>
#include <algorithm>
#include <string.h>
char str1[1100], str2[1100];
int a[510][510];
int max(int a, int b)
{
return a>b ? a : b;
}
int LCS()
{
int len1, len2, i, j;
len1 = strlen(str1);
len2 = strlen(str2);

for(i=0; i<len1; i++)
for(j=0; j<len2; j++)
{
if(str1[i] ==str2[j])
a[i+1][j+1] = a[i][j]+1;//当str1[i] ==str2[j]相等时, 直接在上一个最长子序列上加1;
else
a[i+1][j+1] = max(a[i+1][j],a[i][j+1]);//当str1[i] !=str2[j]相等时,找出 a[i+1][j],a[i][j+1]中谁最大;
}
return a[len1][len2];
}
int main()
{
int LMax;
while(~scanf("%s%s", str1,str2))
{
memset(a,0,sizeof(a));//重置数组a
LMax=LCS();
printf("%d\n", LMax);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息