您的位置:首页 > 大数据 > 人工智能

ZOJ-1094-Matrix Chain Multiplication

2017-04-19 20:41 369 查看
Matrix multiplication problem is a typical example of dynamical programming.
Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed
is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.

There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.
Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1
<= n <= 26), representing the number of matrices in the first part. The next n lines
each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix. 
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"


Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices.
Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

使用栈
#include <iostream>
#include <stack>
#include <string>
using namespace std;
struct Matrix
{
char name;
int row,column;
};
int main()
{
stack <Matrix> m;
Matrix store[26];
int num_of_Matrix;
while(cin>>num_of_Matrix)
{
for(int i=0;i<num_of_Matrix;i++)
cin>>store[i].name>>store[i].row>>store[i].column;
string str;
while(cin>>str)
{
int result=0;
int i=0;
int judge=1;
while(str[i++]!='\0')
{
if(str[i]!='('&&str[i]!=')')
{
for(int j=0;j<num_of_Matrix;j++)
if(store[j].name==str[i])
{
m.push(store[j]);
}
}
else if(str[i]==')')
{
Matrix n,p;
int r;
p=m.top();
n.column=m.top().column;
r=m.top().row;
m.pop();
if(r!=m.top().column)
{
m.push(p);
judge=0;
break;
}
n.row=m.top().row;
m.pop();
m.push(n);
result+=n.column*n.row*r;
}
else
continue;
}
if(!m.empty())
m.pop();
if(judge==0)
cout<<"error"<<endl;
else
cout<<result<<endl;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: