您的位置:首页 > 其它

HDU 1513 Palindrome(思维,DP)

2017-04-19 19:36 363 查看


Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5751    Accepted Submission(s): 1927


Problem Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

 

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

 

Sample Input

5
Ab3bd

 

Sample Output

2

 

Source

IOI 2000

 

Recommend

linle

题意:给出一个长度为n的字符串,求最少添加几个字符可令其变成一个回文串

思路:假设我们有字符串a,其最少添加字符就等于 n - a和a的反串的最长公共子序列长度,因为数据太大会 MLE ,我们需要用滚动数组优化一下。

#include<bits/stdc++.h>
using namespace std;
const int N = 5000 + 10;
char a
,b
;
int dp[2]
;
int main()
{
int n;
while(scanf("%d",&n)==1)
{
scanf("%s",a);
for(int i=0;i<n;i++)
b[i]=a[n-i-1];
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(a[i-1]==b[j-1])
dp[i%2][j]=dp[(i-1)%2][j-1]+1;
else
dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
}
}
printf("%d\n",n-dp[n%2]
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: