您的位置:首页 > 其它

动态规划练习28:Maximum sum

2017-04-19 17:13 363 查看
题目简要:

描述Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
t1     t2
d(A) = max{ ∑ai + ∑aj | 1 <= s1 <= t1 < s2 <= t2 <= n }
i=s1   j=s2


Your task is to calculate d(A).输入The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.

Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.输出Print exactly one line for each test case. The line should contain the integer d(A).样例输入
1

10
1 -1 2 2 3 -3 4 -4 5 -5

样例输出
13

提示In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

这道题就是求最大二子段的问题。

解题思路:

对于每一个数都求一下有这个数的前面的最大子段和,还有后面的最大字段和,最后加起来,放到数组里,求最大就好啦。

附代码:

#include<bits/stdc++.h>
using namespace std;
int a[50005],b[50005],c[50005];
int main()
{
int t;

cin>>t;
while(t--)
{
int n;

cin>>n;
for(int i=1;i<=n;i++)
{

cin>>a[i];
}
int sum=0;

b[0]=-100000;

c[n+1]=-1000000;
for(int i=1;i<=n;i++)

{
if(b[i-1]>sum+a[i])

b[i]=b[i-1];
else b[i]=sum+a[i];

sum=sum+a[i];
if(sum<0)

sum=0;
}

sum=0;
for(int i=n;i!=0;i--)
{
if(c[i+1]>sum+a[i])

c[i]=c[i+1];
else c[i]=sum+a[i];

sum=sum+a[i];
if(sum<0)

sum=0;
}
int answer=-1000000;
for(int i=1;i<=n;i++)
{
if(b[i]+c[i+1]>answer)

answer=b[i]+c[i+1];
}

cout<<answer<<endl;
}
return 0;
}

解题感受:

其实这个问题只要想到就好求啦,虽然WR了4次····
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm