您的位置:首页 > 其它

Eqs POJ - 1840

2017-04-19 16:46 363 查看
题目描述

Consider equations having the following form:

a1x1^3+ a2x2^3+ a3x3^3+ a4x4^3+ a5x5^3=0

The coefficients are given integers from the interval [-50,50].

It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

大致题意: 给你一个等式和取值范围,问有多少种不同的取值方式使得等式成立

思路:先将方程变化成-(a1*x1^3+a2*x2^3) = a3*x3^3+a4*x4^3+a5*x5^3,如此一来缩短了时间复杂度,否则直接五个嵌套for循环必然会超时的

其次,我们把sum作为下标,那么hash数组的上界就取决于a1 a2 x1 x2的组合,四个量的极端值均为50

因此上界为 50*50^3+50*50^3=12500000,由于sum也可能为负数,因此我们对hash[]的上界进行扩展,扩展到25000000,当sum<0时,我们令sum+=25000000存储到hash[],负数就改为正数表示了

由于数组很大,必须使用全局定义

同时由于数组很大,用int定义必然会MLE,因此要用char或者short定义数组,推荐short

代码如下

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue>
#include<map>

using namespace std;

short hash[25000001];
int main()
{
int a1,a2,a3,a4,a5,x1,x2,x3,x4,x5,sum;
while(cin>>a1>>a2>>a3>>a4>>a5)
{
memset(hash,0,sizeof(hash));
for(x1=-50;x1<=50;x1++)
{
if(!x1)
continue;

for(x2=-50;x2<=50;x2++)
{
if(!x2)
continue;
sum=-1*(a1*x1*x1*x1+a2*x2*x2*x2);
if(sum<0)
sum+=25000000;
hash[sum]++;
}
}
int cnt=0;
for(x3=-50;x3<=50;x3++)
{
if(!x3)

4000
continue;
for(x4=-50;x4<=50;x4++)
{
if(!x4)
continue;
for(x5=-50;x5<=50;x5++)
{
if(!x5)
continue;
sum=a3*x3*x3*x3+a4*x4*x4*x4+a5*x5*x5*x5;
if(sum<0)
sum+=25000000;
cnt+=hash[sum];
}
}
}
cout<<cnt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: