您的位置:首页 > 理论基础 > 计算机网络

poj 1087 A Plug for UNIX 【图论-网络流-最大流】

2017-04-19 16:08 656 查看
A Plug for UNIX
Time Limit: 1000MS      Memory Limit: 65536K


Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.

Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling

irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.

Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn’t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.

In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric

characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4

A

B

C

D

5

laptop B

phone C

pager B

clock B

comb X

3

B X

X A

X D

Sample Output

1

题目大意: 一个房间内有n个不同插座,现给出m个电脑以及它要使用的插座类型,又知道不同插座之间可以使用适配器进行转换,给出k种适配器,让你计算没有插座可用的电器的最少数量(即:电器的总数-已经匹配的电器数)?

知识点: 本题,博主第一次用到map容器,先给出一个详细介绍容器的博客

http://www.cnblogs.com/biyeymyhjob/archive/2012/07/22/2603525.html

AC代码:

# include <iostream>
# include <string>
# include <map>
# include <cstdio>
# include <cstring>

using namespace std;

# define MAXN 505
# define INF 1e9 + 100

int Graph[MAXN][MAXN];
int used[MAXN];

map <string, int> Strnum;  //使用map容器来记录插座的编号

int min(int a, int b)
{
return a > b ? b : a;
}

int Dfs(int s, int t, int f)  //Ford-Fulkerson
{
if (s == t)
{
return f;
}
for (int i = 0; i <= t; i++)
{
if (Graph[s][i] > 0 && !used[i])
{
used[i] = 1;
int d = Dfs(i, t, min(f, Graph[s][i]));
if (d > 0)
{
Graph[s][i] -= d;
Graph[i][s] += d;
return d;
}
}
}
return 0;
}

int Maxflow(int s, int t)
{
int maxflow = 0;

while (1)
{
memset(used, 0, sizeof(used));
int f = Dfs(s, t, INF);
if (!f)
{
return maxflow;
}
maxflow += f;
}
}

int main(void)
{
int i, j;
int n, m, k;
int count = 0;
string p, d;

cin >> n;
for (i = 1; i <= n; i++)
{
cin >> p;
Strnum[p] = ++count;
}

cin >> m;
for (i = 1; i <= m; i++)
{
cin >> d >> p;
if (Strnum.find(p) == Strnum.end())
{
Strnum[p] = ++count;
}
Graph[i][m + Strnum[p]] = 1;
}

string p1, p2;

cin >> k;
for (i = 1; i <= k; i++)
{
cin >> p1 >> p2;
if (Strnum.find(p1) == Strnum.end())
{
Strnum[p1] = ++count;
}
if (Strnum.find(p2) == Strnum.end())
{
Strnum[p2] = ++count;
}

Graph[m + Strnum[p1]][m + Strnum[p2]] = INF;  //适配器之间可以无限转换能量
}

int s = 0; //源点
int t = m + count + 1; //汇点

for (i = 1; i <= m; i++)
{
Graph[s][i] = 1;  //所有设备与源点相连
}
for (i = 1; i <= n; i++)
{
Graph[m + i][t] = 1; //所有之前房间里有的插座与汇点相连
}

cout << m - Maxflow(s, t) << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  图论 网络流 最大流