您的位置:首页 > 其它

ZOJ 2418 Matrix

2017-04-19 13:25 351 查看
Given an n*n matrix A, whose entries Ai,j are integer numbers ( 0 <= i < n, 0 <= j < n ). An operation SHIFT at row i ( 0 <= i < n ) will move the integers in the row one position right, and the rightmost integer will wrap around to the leftmost
column.



You can do the SHIFT operation at arbitrary row, and as many times as you like. Your task is to minimize



Input

The input consists of several test cases. The first line of each test case contains an integer n. Each of the following n lines contains n integers, indicating the matrix A. The input is terminated by a single line with an integer -1. You may assume that
1 <= n <= 7 and |Ai,j| < 104.

Output

For each test case, print a line containing the minimum value of the maximum of column sums.

Sample Input

2

4 6

3 7

3

1 2 3

4 5 6

7 8 9

-1

Sample Output

11

15

直接爆搜就可以过。#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<map>
#include<algorithm>
using namespace std;
typedef long long LL;
#define rep(i,j,k) for (int i=j;i<=k;i++)
#define per(i,j,k) for (int i=j;i>=k;i--)
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
typedef pair<int,int> pii;
const int N = 15;
const int INF=0x7FFFFFFF;
int n,a

,b
,ans;

int calc()
{
int res=-INF;
rep(i,0,n-1)
{
int cnt=0;
rep(j,0,n-1)
{
cnt+=a[j][(i+b[j])%n];
}
res=max(res,cnt);
}
return res;
}

void dfs(int x)
{
if (x==n)
{
ans=min(ans,calc());
return;
}
rep(i,0,n-1)
{
b[x]=i;
dfs(x+1);
}
}

int main()
{
while (~inone(n)&&n!=-1)
{
rep(i,0,n-1) rep(j,0,n-1) inone(a[i][j]);
ans=INF; b[0]=0; dfs(1);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  zoj