您的位置:首页 > 其它

NYOJ题目5

2017-04-19 11:05 155 查看
NYOJ题目5Binary String Matching

Binary String Matching

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入

3

11

1001110110

101

110010010010001

1010

110100010101011

样例输出

3

0

3

#include<stdio.h>
#include<string.h>
int main ()
{
int n,m;
char a[20],b[1010];
scanf("%d",&n);
getchar();
while(n--)
{
int s=0,t=0;
gets(a);
gets(b);
char *c=b;
while(c!=NULL)
{
c=strstr(c+t,a);/*这里是关键,如果c不加1将会一直循环同一个数下去*/
if(c==NULL)
break;
t=1;
s++;
}
printf("%d\n",s);
}
return 0;
}


我在看c prime plus 的时候看到指针忽然就有想法这样写,只是当时用的是strchr()也是这样的形式,当时我试了很久(指针用的不是特别好),然后也算是搞出来了,现在遇到这道题也就试试,发现也可以成功,于是就写出来了,比起之前用的暴力法要好很多,而且也算是开始领悟到了指针的神奇。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: