您的位置:首页 > 其它

ZOJ Problem Set - 3872 Beauty of Array

2017-04-19 10:16 337 查看
Beauty of Array

Time Limit: 2 Seconds Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3

5

1 2 3 4 5

3

2 3 3

4

2 3 3 2

Sample Output

105

21

38

Author: LIN, Xi

Source: The 12th Zhejiang Provincial Collegiate Programming Contest

/* 由子串相邻推出(一般都是和前一个有关系)
3
1 2 3

1  1
2  1 2
2
3  1 2 3
2 3
3
当前项:后面一项是前面一项在加上自己(a*i) ans = ans + a*i;
3
2 3 3

2  2
3  2 3
3
3  2 3 3
3 3
3
重复的处理为,记录输入的数是第几项,减去就可去重ans = ans + (i - w[a])*a
*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
const int N = 1000009;
int main(int argc, char *argv[])
{
int cases,n,a;
cin >> cases;
while (cases--) {
int w
= {0};
long long ans,dpt;
dpt = 0, ans = 0;
cin >> n;
for (int i = 1; i <= n; i++) {
cin >> a;
dpt += a * (i - w[a]);
ans += dpt;
w[a] = i;
}
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: