您的位置:首页 > 其它

lightOj1078 同余定理

2017-04-19 09:28 309 查看
If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1’s. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3’s then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit (1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

(a+b)%n=(a%n+b%n)%n

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#define MM(s,q) memset(s,q,sizeof(s))
#define INF 0x3f3f3f3f
#define MAXN 1005
#define Lchild id<<1
#define Rchild (id<<1)+1
#define ll long long
#define FILE  freopen("data.in","r",stdin)
using namespace std;
int x[50000], len;
int main() {
int T, n, k, icase = 1;
cin >> T;
while (T--) {
cin >> n >> k;
len = 1;
int ans = k % n;

while (ans) {
ans = (ans * 10 + k) % n;
len++;
}
printf("Case %d: %d\n", icase++, len);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: