您的位置:首页 > 其它

Poj3278 Catch That Cow ( BFS

2017-04-18 23:16 337 查看

Catch That Cow

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 88609Accepted: 27757
DescriptionFarmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
InputLine 1: Two space-separated integers: N and KOutputLine 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.Sample Input5 17Sample Output4

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
#define ll long long
#define N 200010
const int mod = 1e9+7;
int n, k;
struct node {
int x, step;
}p
;                  //*2数据要开大两倍2233 没开会RE
queue<node> q;
bool vis
;
int bfs()
{
vis
= true;
p
.x = n;
p
.step = 0;
q.push(p
);
int pos, step;
while(!q.empty()) {
pos = q.front().x;
step = q.front().step;
q.pop();
if(pos==k) return step;
if(!vis[pos-1] && pos>0) {   // pos必须大于0
vis[pos-1] = true;
p[pos-1].x = pos-1;
p[pos-1].step = step+1;
q.push(p[pos-1]);
}
if(pos<k) {
if(!vis[pos+1]) {
vis[pos+1] = true;
p[pos+1].x = pos+1;
p[pos+1].step = step+1;
q.push(p[pos+1]);
}
if(!vis[pos*2]) {
vis[pos*2] = true;
p[pos*2].x = pos*2;
p[pos*2].step = step+1;
q.push(p[pos*2]);
}
}
}
}
int main()
{
while(~scanf("%d%d",&n,&k)) {
memset(vis,false,sizeof(vis));
memset(p,0,sizeof(p));
while(!q.empty()) q.pop();
printf("%d\n",bfs());

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: