您的位置:首页 > 其它

hdu 1009 FatMouse' Trade(贪心)

2017-04-18 16:57 459 查看
Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative
integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain 

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1 

Sample Output

13.333
31.500
//
//  main.cpp
//  160929
//
//  Created by 刘哲 on 17/4/13.
//  Copyright © 2016年 my_code. All rights reserved.
//
//#include <bits/stdc++.h>

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#define lowbit(x) (x&-x)
using namespace std;
#define ll long long
struct sa
{
int j;
int f;
double awk;
}data[2002];
int cmp(const sa & a,const sa & b)
{
return (a.awk)>(b.awk);
}
int main()
{
int m,n,k;
double sum;
while(cin>>m>>n)
{
sum=0.0;
k=0;
if(m==-1&&n==-1)
break;
for(int i=0;i<n;i++)
{
cin>>data[i].j>>data[i].f;
data[i].awk=(double)data[i].j/(double)data[i].f;
}
sort(data,data+n,cmp);
for(int k=0;k<n;k++)
{
if(m>=data[k].f)
{
sum+=data[k].j;
m=m-data[k].f;
}
else
{
sum+=(double)m*data[k].awk;
break;
}
}
printf("%.3lf\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心