您的位置:首页 > 产品设计 > UI/UE

POJ 1458 Common Subsequence(LCS)

2017-04-18 10:01 417 查看


Common Subsequence

 

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly
increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X
and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp


Sample Output
4
2
0


裸题,不解释,不好意思我又刷博客了。。。

1)最长公共子序列的长度的动态规划方程

    设有字符串a[0...n],b[0...m],下面就是递推公式。字符串a对应的是二维数组num的行,字符串b对应的是二维数组num的列。

    


    另外,采用二维数组flag来记录下标ij的走向。数字"1"表示,斜向下;数字"2"表示,水平向右;数字"3"表示,竖直向下。这样便于以后的求解最长公共子序列。

#include <iostream>
#include <stdio.h>
#include <cstring>
using namespace std;
int main()
{
int i,j,dp[2][10086],t;
char a[10086],b[10086];
bool now,pre;
while(~scanf("%s%s",a,b))
{
memset(dp,0,sizeof(dp));
int lena=strlen(a),lenb=strlen(b);
for(now=1,pre=0,i=0; i<lena; i++)
for(swap(now,pre),j=0; j<lenb; j++)
if(a[i]==b[j])
dp[now][j+1]=dp[pre][j]+1;
else
dp[now][j+1]=dp[pre][j+1]>dp[now][j]?dp[pre][j+1]:dp[now][j];
printf("%d\n",dp[now][lenb]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: