您的位置:首页 > 其它

POJ-1017 Packets

2017-04-17 22:10 232 查看
A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products
have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem
of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the
smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output
file corresponding to the last ``null'' line of the input file.

Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0


Sample Output
2
1
思路:6*6 5*5 4*4 3*3都会单独占一个箱子
呢就先找这几个箱子的数目case_n=num[6]+num[5]+num[4]+(num[3]+3)/4;
然后再看剩下空间还能放多少2*2和1*1
case2= num[4]*5+space_three[num[3]%4][0];
case1= num[5]*11+space_three[num[3]%4][1];

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
int space_three[4][2]={{0,0},{5,7},{3,6},{1,5}},case_n; //2*2,1*1
int num[7];
int main(){
// freopen("2.txt","r",stdin);
int sum;
int case2,case1; //边角还能放下几个2*2和1*1
while(1){
sum=0;
for(int i=1;i<=6;i++){
scanf("%d",&num[i]);
sum+=num[i];
}
if(sum==0){
break;
}
case_n=num[6]+num[5]+num[4]+(num[3]+3)/4;
case2= num[4]*5+space_three[num[3]%4][0];
case1= num[5]*11+space_three[num[3]%4][1];
if(case2>=num[2]){
case1+=(case2-num[2])*4; //把多出来的2*2换成1*1
}
else{
case_n+=(num[2]-case2+8)/9;
case1+=(9-(num[2]-case2)%9)*4;
}
if(case1<num[1]
4000
){
case_n+=(num[1]-case1+35)/36;
}
printf("%d\n",case_n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: