您的位置:首页 > 其它

简单枚举类型——植物与颜色

2017-04-17 19:42 351 查看

Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 

Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。

Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 

Example Input

blue
yellow
purple


Example Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.


Hint

 请用枚举类型实现。 
import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
while(in.hasNext()){
String a = in.nextLine();
Color color = new Color(a);
color.show();
}
in.close();
}
}
class Color{
String a;
public Color(String a){
this.a = a;
}
public void show(){
if(a.compareTo("red")==0)
System.out.println("Rose are red.");
else if(a.compareTo("orange")==0)
System.out.println("Poppies are orange.");
else if(a.compareTo("yellow")==0)
System.out.println("Sunflower are yellow.");
else if(a.compareTo("green")==0)
System.out.println("Grass are green.");
else if(a.compareTo("blue")==0)
System.out.println("Bluebells are blue.");
else if(a.compareTo("violet")==0)
System.out.println("Violets are violet.");
else
System.out.println("I don't know about the color " + a + ".");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: