您的位置:首页 > 其它

HDU 1841 Find the Shortest Common Superstring(KMP)

2017-04-17 14:37 633 查看

Find the Shortest Common Superstring

[align=left]Problem Description[/align]
The shortest common superstring of 2 strings S1 and S2 is a string S with the minimum number of characters which contains both S1 and S2 as a sequence of consecutive characters. For instance,
the shortest common superstring of “alba” and “bacau” is “albacau”.

Given two strings composed of lowercase English characters, find the length of their shortest common superstring.

 

[align=left]Input[/align]
The first line of input contains an integer number T, representing the number of test cases to follow. Each test case consists of 2 lines. The first of these lines contains the string S1 and the second line contains the
string S2. Both of these strings contain at least 1 and at most 1.000.000 characters.

 

[align=left]Output[/align]
For each of the T test cases, in the order given in the input, print one line containing the length of the shortest common superstring.

 

[align=left]Sample Input[/align]

2
alba
bacau
resita
mures

 

[align=left]Sample Output[/align]

7
8

两次KMP;

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e6+10;
char s1[maxn],s2[maxn];
int next1[maxn];

void get_next(char *s){
next1[0]=0;
int len=strlen(s);
int k=0;
for(int p=1;p<len;p++){
while(k>0 && s[k]!=s[p])
k=next1[k-1];

if(s[k]==s[p])k++;

next1[p]=k;
}
}

int KMP(char *s1,char *s2){
get_next(s1);
int l1=strlen(s1);
int l2=strlen(s2);
int i=0,j=0;
while(i<l1 && j<l2){
if(s1[i]==s2[j]){
i++;j++;
}

else if(i==0)j++;

else i=next1[i-1];
}

//和hdu1867几乎一模一样的题,但是1867要加上下面这句,因为要打印字符串,而这里加上就会错!!!!!(两次交换顺序的kmp,应该没影响吧,但是加上就是A不了)
//if(i<l1 || (i==l1&&j==l2))return i;
return i;
}
int main(){
int T;
scanf("%d",&T);
while(T--){
scanf("%s%s",s1,s2);

int l1=KMP(s1,s2);
int l2=KMP(s2,s1);

int Max=max(l1,l2);
printf("%d\n",strlen(s1)+strlen(s2)-Max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: