您的位置:首页 > 其它

HDU 1009 FatMouse' Trade(贪心)

2017-04-17 14:13 471 查看


FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 76068    Accepted Submission(s): 26058


Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All
integers are not greater than 1000.

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
4000

24 15
15 10
-1 -1

 

Sample Output

13.333
31.500

 

Author

CHEN, Yue

 

Source

ZJCPC2004

 

Recommend

JGShining

题意:我们要用M磅猫粮去换豆子,分别能用F [ i ] * a % 磅猫粮换到 J  [ i ]  * a %磅豆子,问我们最多可以换多少豆子

#include<bits/stdc++.h>
using namespace std;
const int N = 1000 + 10;
struct xx
{
int val,vol;
double p; ///p为性价比
} a
;
int cmp(xx a, xx b)
{
return a.p>b.p;
}
int main()
{
int m,n;
while(scanf("%d%d",&m,&n)==2)
{
if(m==-1&&n==-1)
break;
for(int i=0; i<n; i++)
{
scanf("%d%d",&a[i].val,&a[i].vol);
a[i].p=(double)a[i].val/a[i].vol;
}
sort(a,a+n,cmp);
double ans=0,sum=0;
for(int i=0; i<n; i++)
{
if(sum+a[i].vol<=m)
{
sum+=a[i].vol;
ans+=a[i].val;
}
else
{
ans+=(m-sum)*a[i].p;
break;
}
}
printf("%.3f\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: