您的位置:首页 > 产品设计 > UI/UE

ZOJ2136-Longest Ordered Subsequence

2017-04-17 11:27 381 查看
Longest Ordered Subsequence
Time Limit: 2 Seconds      Memory Limit: 65536 KB

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2
< ... < iK <= N. For example, the sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e.g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences of this sequence are of length 4, e.g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input
The first line of input contains the length of sequence N (1 <= N <= 1000). The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated
by spaces.

Output
Output must contain a single integer - the length of the longest ordered subsequence of the given sequence.

This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank
line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.



Sample Input

1

7

1 7 3 5 9 4 8

Sample Output
4

Source: Northeastern Europe 2002, Far-Eastern Subregion

题意:给出一串数字,找出最长上升子序列

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int main()
{
int t,cas=0;
scanf("%d",&t);
while(t--)
{
if(cas) printf("\n");
else cas=1;
int n,cnt=1;
scanf("%d",&n);
int a[1005],b[1005];
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
if(i==1) b[cnt++]=a[i];
else
{
int k=lower_bound(b+1,b+cnt,a[i])-b;
if(k==cnt) b[cnt++]=a[i];
else b[k]=a[i];
}
}
printf("%d\n",cnt-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: