您的位置:首页 > 其它

1028. List Sorting (25)-PAT甲级

2017-04-17 03:51 381 查看

题目:

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1

3 1

000007 James 85

000010 Amy 90

000001 Zoe 60

Sample Output 1

000001 Zoe 60

000007 James 85

000010 Amy 90

Sample Input 2

4 2

000007 James 85

000010 Amy 90

000001 Zoe 60

000002 James 98

Sample Output 2

000010 Amy 90

000002 James 98

000007 James 85

000001 Zoe 60

Sample Input 3

4 3

000007 James 85

000010 Amy 90

000001 Zoe 60

000002 James 90

Sample Output 3

000001 Zoe 60

000007 James 85

000002 James 90

000010 Amy 90

解答:

要是其他排序题都这么简单就好了呜呜呜呜,写这种题就要一起哈成哈哈哈哈

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100010;
struct Student{
int id;
char name[10];
int score;
}stu[maxn];
bool cmp1(Student a,Student b){
return a.id<b.id;
}
bool cmp2(Student a,Student b){
int s=strcmp(a.name,b.name);
if(s!=0)return s<0;
else return a.id<b.id;
}
bool cmp3(Student a,Student b){
if(a.score!=b.score)return a.score<b.score;
else return a.id<b.id;
}
int main(){
int x,y;
scanf("%d%d",&x,&y);
for(int i=0;i<x;i++){
scanf("%d%s%d",&stu[i].id,stu[i].name,&stu[i].score);
}
if(y==1)sort(stu,stu+x,cmp1);
else if(y==2)sort(stu,stu+x,cmp2);
else sort(stu,stu+x,cmp3);
for(int i=0;i<x;i++){
printf("%06d %s %d\n",stu[i].id,stu[i].name,stu[i].score);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: