您的位置:首页 > 其它

fzuoj 2218 Simple String Problem(状态压缩dp)

2017-04-16 19:37 274 查看
Recently, you have found your interest in string theory. Here is an interesting question about strings.

You are given a string S of length n consisting of the first k lowercase letters.

You are required to find two non-empty substrings (note that substrings must be consecutive) of S, such that the two substrings don't share any same letter. Here comes the question, what is the maximum product of the two substring
lengths?

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, the first line consists of two integers n and k. (1 <= n <= 2000, 1 <= k <= 16).

The second line is a string of length n, consisting only the first k lowercase letters in the alphabet. For example, when k = 3, it consists of a, b, and c.

Output

For each test case, output the answer of the question.

Sample Input
4
25 5
abcdeabcdeabcdeabcdeabcde
25 5
aaaaabbbbbcccccdddddeeeee
25 5
adcbadcbedbadedcbacbcadbc
3 2
aaa

Sample Output
6
150
21
0

Hint
One possible option for the two chosen substrings for the first sample is "abc" and "de".

The two chosen substrings for the third sample are "ded" and "cbacbca".

In the fourth sample, we can't choose such two non-empty substrings, so the answer is 0. 

题意:给出一个长度为n的字符串包括k个小写字母,求该串中两个不相交并且没有公共元素的子串长度的乘积的最大值。

题解:状态压缩dp,对于一个状态state,求这个状态下在该字符串中的最大长度。

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<vector>
#include<stack>
#include<queue>
#include<algorithm>
#include<sstream>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int dp[70010];
int main()
{
int T;
cin>>T;
while(T--)
{
int n,k;
cin>>k>>n;
string str;
cin>>str;
memset(dp,0,sizeof(dp));
for(int i=0;i<=k-1;i++)//遍历求得state状态下的最大值
{
int state=0;//state是k个字符是否被访问的状态
for(int j=i;j<=k-1;j++)
{
state=state|(1<<(str[j]-'a'));//将该字符标记
dp[state]=max(dp[state],j-i+1);
}
}
for(int i=0;i<(1<<n);i++)
{
for(int j=0;j<=n-1;j++)
if(i&(1<<j))
dp[i]=max(dp[i],dp[i^(1<<j)]);//设状态i为011,dp[i]为只包含a,只包含b,和a,b都包含的连续子串的个数
}
int maxx=0;
for(int i=0;i<(1<<n);i++)
maxx=max(maxx,dp[i]*dp[((1<<n)-1)^i]);
cout<<maxx<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: