您的位置:首页 > 其它

ZOJ2388 Beat the Spread!

2017-04-16 19:18 447 查看
Beat the Spread!
Time Limit: 2 Seconds      Memory Limit: 65536 KB

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game.
Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.
Given the winning numbers for each type of bet, can you deduce the final scores?

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and
(absolute) difference between the two final scores.

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always
non-negative integers.

Sample Input
2

40 20

20 40

Sample Output
30 10

impossible

题目的意思是给出两个数的和和这两个数的差,问能不能找出这样两个非负整数。
#include <iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<set>
#include<cstring>
using namespace std;
#define LL long long

int main()
{
int a,b,T;
scanf("%d",&T);
while(T--)
{scanf("%d%d",&a,&b);
if((a+b)%2==1){
printf("impossible\n");
continue;
}
int x=(a+b)/2;
int y=a-x;
if(x<y)
swap(x,y);
if(x>=0&&y>=0)
printf("%d %d\n",x,y);
else
printf("impossible\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: