您的位置:首页 > 其它

HDU 1372 Knight Moves

2017-04-15 20:20 381 查看


Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11333    Accepted Submission(s): 6658


Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of
the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

 

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 

 

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.". 

 

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

 

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

 

Source

University of Ulm Local Contest 1996

 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1072 1240 1548 1180 1401 

 

Statistic | Submit | Discuss | Note

幸福来的太突然,结果一直不对,然后发现是dir[8][2]我写错了,改了一交就对!

普通BFS求最短路径问题

然后被科普了国际象棋的骑士走法:走3*2矩阵对角线,还有走的是格子,不是点!!

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#define INF 1000000
using namespace std;
struct point{
int x,y,step;
};
int ex,ey;
int dir[8][2]={1,2,2,1,1,-2,2,-1,-1,2,-2,1,-1,-2,-2,-1};
int minstep[100][100];
int vis[100][100];
queue<point>q;
void bfs(point p){
int i;
q.push(p);
while(!q.empty()){
point now;
now=q.front(); q.pop();
for(i=0;i<8;i++){
int x=now.x+dir[i][0];
int y=now.y+dir[i][1];
if(x>0&&x<=8&&y>0&&y<=8&&!vis[x][y]){
point t; vis[x][y]=1;
t.x=x; t.y=y; t.step=now.step+1;
if(t.step<minstep[x][y]){
minstep[x][y]=t.step;
q.push(t);
}
}
}
}
printf("%d knight moves.\n",minstep[ex][ey]);
}
int main(){
int i,j,b1,b2;
char a1,a2;
while(~scanf("%c%d %c%d",&a1,&b1,&a2,&b2)){
getchar();
memset(vis,0,sizeof(vis));
for(i=1;i<=8;i++){
for(j=1;j<=8;j++){
minstep[i][j]=INF;
}
}
printf("To get from %c%d to %c%d takes ",a1,b1,a2,b2);
point s;
s.x=a1-'a'+1; s.y=b1; s.step=0; minstep[s.x][s.y]=0;
ex=a2-'a'+1; ey=b2;
vis[s.x][s.y]=1;
bfs(s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: