您的位置:首页 > 其它

POJ 1113 Wall (凸包+求周长)

2017-04-15 17:16 399 查看
Wall

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 21502Accepted: 7048
Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful
brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King
finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact
amount of resources that are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices
in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet
that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides
of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number
of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200


Sample Output
1628


Hint

结果四舍五入就可以了
栈内存的是凸包的点,一样可以求面积
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const double eps = 1e-8;
const double pi = acos(-1.0);
int sgn(double x)
{
if(fabs(x) < eps) return 0;
if(x < 0) return -1;
return 1;
}
struct Point
{
double x, y;
Point(double xx = 0, double yy = 0) : x(xx), y(yy){} //这里一定要 赋初值为0,要不编译错误。。
Point operator - (const Point &b) const
{
return Point(x-b.x, y-b.y);
}
double operator ^ (const Point &b) const
{
return x*b.y-y*b.x;
}
double operator *(const Point &b) const
{
return x*b.x + y*b.y;
}
void input()
{
scanf("%lf%lf", &x, &y);
}
};
double dist(Point a, Point b)
{
return sqrt((a-b)*(a-b));
}
const int maxn = 1010;
Point list[maxn];
int Stack[maxn], top;
int cmp(Point p1, Point p2)
{
double temp = (p1-list[0])^(p2-list[0]);
if(sgn(temp) > 0) return 1;
else if(sgn(temp) == 0 && sgn(dist(p1, list[0])-dist(p2, list[0])) <= 0)
return 1;
return 0;
}
void Graham(int n)
{
Point p0;
int k = 0;
p0 = list[0];
for(int i = 1; i < n; i++)
{
if((p0.y > list[i].y) || (p0.y == list[i].y && p0.x > list[i].x))
{
p0 = list[i];
k = i;
}
}
swap(list[k], list[0]);
sort(list+1, list+n, cmp);
if(n == 1)
{
top = 1;
Stack[0] = 0;
return;
}
if(n == 2)
{
top = 2;
Stack[0] = 0;
Stack[1] = 1;
return;
}
Stack[0] = 0;
Stack[1] = 1;
top = 2;
for(int i = 2; i < n; i++)
{
while(top > 1 && sgn((list[Stack[top-1]]-list[Stack[top-2]])^(list[i]-list[Stack[top-2]])) <= 0)
top--;
Stack[top++] = i;
}
}
//Point p[20];
//double L[20];
//int v[20];
int main()
{
int n, l;
while(~scanf("%d%d", &n, &l))
{
for(int i = 0; i < n; i++)
list[i].input();
Graham(n);
double ans = 0;
for(int i = 0; i < top; i++)
ans += dist(list[Stack[i]], list[Stack[(i+1)%top]]);
ans += 2*pi*l;
printf("%d\n", int(ans+0.5));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: