您的位置:首页 > 其它

HDU 1016 Prime Ring Problem(DFS)

2017-04-15 11:54 411 查看


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 48783    Accepted Submission(s): 21502


Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

6
8

 

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

Source

Asia 1996, Shanghai (Mainland China)

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1312 1072 1175 1181 1026 

 

Statistic | Submit | Discuss | Note

直接素数打表会快一点吧,反正只是40以内的素数

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int prime[40]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};
int n;
int vis[25]; //存储是否遍历过
int a[25]; //存储正确的序列
void dfs(int num){
int i;
if(num==n&&prime[a[n-1]+a[0]]){
for(i=0;i<n-1;i++){
printf("%d ",a[i]);

}
printf("%d\n",a[n-1]);
}
else {
for(i=2;i<=n;i++){
if(vis[i]==0&&prime[i+a[num-1]]){
vis[i]=1;
a[num++]=i;
dfs(num);
vis[i]=0;
num--;
}
}
}
}
int main(){
int k=0;
while(~scanf("%d",&n)){
k++;
printf("Case %d:\n",k);
memset(vis,0,sizeof(vis));
a[0]=1;
dfs(1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: