您的位置:首页 > Web前端

HDOJ 1829 A Bug's Life (种类并查集)

2017-04-14 17:02 309 查看
Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 

Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 

InputThe first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a
single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
OutputThe output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent
with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4


Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


Hint
Huge input,scanf is recommended.

题意:只有两种性别,通过推理看是否存在同性恋。
思路:种类并查集,0表示男,1表示女,如果与根节点距离为偶数的话,性别与根节点相同,奇数的话相反,通过不断合并根节点,更新子节点找父亲节点相同且性别相同的有联系的点。由于只有两种性别所以将孩子节点到根节点的距离取余2表示根节点的性别,然后根节点确定就需要根据根节点判断孩子节点的性别。
代码:
#include <iostream>
#include<stdio.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<map>
#include<vector>
#include<deque>
#define ll long long
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
#include<iostream>
#include<stdlib.h>
#define Size 2005
using namespace std;
int f[2003],r[2003],flag,n;
int findd(int x)
{
if(x!=f[x])
{
int tt=findd(f[x]);
r[x]=(r[x]+r[f[x]])%2;
f[x]=tt;return f[x];
}
else
return f[x];
}
void join(int a,int b)
{
int fx=findd(a);
int fy=findd(b);
if(fx==fy)
{
if(r[a]==r[b])
{
flag=1;
}

}
else
{
f[fx]=fy;
r[fx]=(r[a]+r[b]+1)%2;
}
}
void init()
{
for(int i=1; i<=n; i++)
{
r[i]=0;
f[i]=i;
}
}
int main()
{
int t;
scanf("%d",&t);
for(int p=1; p<=t; p++)
{
int m;
scanf("%d%d",&n,&m);
init();
flag=0;
int a1,b1;
for(int i=0; i<m; i++)
{
scanf("%d%d",&a1,&b1);
if(flag==0)
{
join(a1,b1);
}
}
printf("Scenario #%d:\n",p);
if(flag==1)
{
printf("Suspicious bugs found!\n");
}
else
printf("No suspicious bugs found!\n");
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: