您的位置:首页 > 其它

Proud Merchants HDU

2017-04-14 10:53 211 查看
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any
more.

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.

If he had M units of money, what’s the maximum value iSea could get?

InputThere are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

OutputFor each test case, output one integer, indicating maximum value iSea could get.

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output
5
11


以最低价格要求与实际价格的差值作为关键字进行排序,然后当作01背包处理

A:p1,q1 B: p2,q2,先选A,则至少需要p1+q2的容量,而先选B则至少需要p2+q1,如果p1+q2>p2+q1

因此该题要确保Q[i]-P[i]小的先被”挑选“,差值越小使用它的价值越大(做出的牺牲越小).

#include<stdio.h>

#include<math.h>

#include<string.h>

#include<iostream>

#include<algorithm>

using namespace std;

int n,m;

int dp[5500];

struct node

{

    int p;

    int q;

    int v;

}a[5500];

int cmp(node a1,node a2)

{

    return a1.q-a1.p<a2.q-a2.p;

}

int main()

{

    while(~scanf("%d%d",&n,&m))

    {

        memset(dp,0,sizeof(dp));

        for(int i=0;i<n;i++)

            scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);

           sort(a,a+n,cmp);

           for(int i=0;i<n;i++)

           {

               for(int j=m;j>=a[i].q;j--)

                dp[j]=max(dp[j],dp[j-a[i].p]+a[i].v);

           }

           printf("%d\n",dp[m]);

    }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: