您的位置:首页 > 其它

POJ-1611-The Suspects

2017-04-14 10:10 197 查看
Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 34902Accepted: 16954
Description
Severe
acute respiratory syndrome (SARS), an atypical pneumonia of unknown
aetiology, was recognized as a global threat in mid-March 2003. To
minimize transmission to others, the best strategy is to separate the
suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are
many student groups. Students in the same group intercommunicate with
each other frequently, and a student may join several groups. To prevent
the possible transmissions of SARS, the NSYSU collects the member lists
of all student groups, and makes the following rule in their standard
operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects
when a student is recognized as a suspect. Your job is to write a
program which finds all the suspects.Input
The
input file contains several cases. Each test case begins with two
integers n and m in a line, where n is the number of students, and m is
the number of groups. You may assume that 0 < n <= 30000 and 0
<= m <= 500. Every student is numbered by a unique integer between
0 and n?1, and initially student 0 is recognized as a suspect in all
the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself
representing the number of members in the group. Following the number of
members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.Output
For each case, output the number of suspects in one line.Sample Input100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0Sample Output4
1
1
要看懂题意,因为理解错了题意,写了好久也没写出来,看了别人的代码才知道理解错了,英语伤不起啊。
总体来说这道题也挺简单,只是多了一个计数数组而已。


#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN=30000+5;
int par[MAXN];
int ran[MAXN];//计数数组
int find(int x){
return par[x]==x ? x : par[x]=find(par[x]);
}
void unite(int x,int y){
x = find(x);
y = find(y);
if(x==y)
return ;
par[y] = x;
ran[x] += ran[y];
}
int main(){
int n;
int numPars,numFriends;
bool flag = false;
while(cin >> numPars >> n){
if(numPars == 0){
break;
}
for(int i=0; i<numPars; i++){
par[i] = i;
ran[i] = 1;
}
int a,b,c;
while(n--){
cin >> a >> b;
for(int i=1; i<a; i++){
cin >> c;
unite(b,c);
}
}
cout << ran[find(0)] << endl;//不能直接输出ran[0];
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: