您的位置:首页 > 其它

相邻区域染色最小染色数问题 POJ 1129

2017-04-14 00:40 351 查看
本题水题,有个四面图定理,最多只有四个多边形(节点)两两相邻。

四色定理的“相邻”是指两块多边形地区“至少一条边重合”才为之相邻

“至少一条边重合”同时也隐含了“任意边(线段)不正规相交






所有颜色数最多只可能四种,枚举dfs判断是否矛盾即可。

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby
repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of
channels required.

Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet
starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line
has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels
is in the singular form when only one channel is required.

Sample Input
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0


Sample Output
1 channel needed.
3 channels needed.
4 channels needed.


width代表可能的颜色数。  本题我是用邻接表存储的图。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<list>

using namespace std;
const int maxn = 30;

bool mp[maxn][maxn];
list<int> node[maxn];
int color[maxn];

int n;

bool judge(int x,int y) {
list<int>::iterator i;
for(i = node[x].begin(); i != node[x].end(); i++) {
if(y == color[(*i)]) {
return false;
}
}
return true;
}

bool dfs(int x,int width) {
if(x>=n) {
return true;
}
for(int i=1; i<=width; i++) {
if(judge(x,i)) {
color[x] = i;
if(dfs(x+1,width)) {
return true;
}
}
}
return false;
}

char ch[maxn];

int main( ) {
int t;
while(scanf("%d",&n)!=EOF&&n) {
//memset(color,0,sizeof(color));
for(int i=0;i<maxn;i++)
node[i].clear();
getchar();
t = n;
while(t--) {
gets(ch);
//cout<<ch<<"\n";
for(int i=2;i<strlen(ch);i++) {
node[ch[0] - 'A'].push_back(ch[i] - 'A');
}
}
for(int i=1;i<=4;i++) {
memset(color,0,sizeof(color));
if(dfs(0,i)) {
if(i==1)
printf("1 channel needed.\n");
else
printf("%d channels needed.\n",i);
break;
}
}
}
}
下面是几个相关写得不错的博客

http://blog.csdn.net/lyy289065406/article/details/6647986

http://blog.csdn.net/lanjiangzhou/article/details/8993148

C++链表的使用方法:
C++ List的用法(整理)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: