您的位置:首页 > 编程语言 > Java开发

南阳理工ACM 题目216 A problem is easy

2017-04-13 23:37 405 查看

A problem is easy

[align=center]时间限制:1000 ms  |  内存限制:65535 KB[/align]
[align=center]难度:3[/align]

     描述
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..



One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.

Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

     输入

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).
     输出
For each case, output the number of ways in one line
     样例输入

     2

     1

     3

     样例输出

     0

     1

import java.io.BufferedInputStream;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner cin = new Scanner(new BufferedInputStream(System.in));
int T = cin.nextInt();
while(T-->0){
int num = cin.nextInt();
int N = 0;
for(int i=2;i<=Math.sqrt(num+1);i++){
if((num+1)%i==0)
N++;
}
System.out.println(N);
}
}

}


    
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM java 南阳理工