您的位置:首页 > 其它

HDU - 1102 Constructing Roads(最小生成树kruskal)

2017-04-13 22:13 411 查看
点击打开题目链接


Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 22472    Accepted Submission(s): 8642


Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

 

Sample Output

179

 

Source

kicc

 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1233 1301 1162 1232 1875 

 

Statistic | Submit | Discuss | Note

最小生成树kruska裸题。

题目大意:N个城镇之间想修公路直接或者间接相连,已知各城镇之间的距离,给出已经存在的公路,求出要使得所有城镇直接或间接相通最短修路距离。

思路:先用二维数组map存两城镇间距离,如果已经存在公路,两点之间map为0,然后用一个结构体存两地信息和权值,然后每个点遍历,如果起点与终点根节点不同,则说明两地之间直接或间接没有公路,把距离加到sum里,最后输出sum即可。

附上AC代码:

#include<bits/stdc++.h>

using namespace std;
const int maxn=100+5;
int par[maxn];
int map_[maxn][maxn];
int n,m;
int fx,fy;

struct edges
{
int begin_;
int end_;
int val;
}edge[maxn*maxn];

bool cmp(edges a,edges b)
{
return a.val<b.val;
}

void init()
{
for(int i=0;i<maxn;i++)
par[i]=i;
}

int find(int a)
{
if(a==par[a])return a;
return par[a]=find(par[a]);
}

int kruskal(int cnt)
{
init();
int sum=0;
for(int i=1;i<=cnt;i++)
{
int dx=find(edge[i].begin_);
int dy=find(edge[i].end_);
if(dx!=dy)
{
if(dx>dy)
par[dx]=dy;
else if(dx<dy)
par[dy]=dx;
sum+=edge[i].val;
}
}
return sum;
}

int main()
{
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
scanf("%d",&map_[i][j]);
scanf("%d",&m);
while(m--)
{
scanf("%d%d",&fx,&fy);
map_[fx][fy]=map_[fy][fx]=0;
}
int cnt=1;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
edge[cnt].begin_=i;
edge[cnt].end_=j;
edge[cnt++].val=map_[i][j];
}
cnt--;
sort(edge+1,edge+cnt+1,cmp);
printf("%d\n",kruskal(cnt));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  图论 Kruskal hdu acm